Anzeige

In Formeln zusätzlichen Spaltenbereich addieren.

Mehr
28 Jun 2020 10:15 #1 von Chris
Hallo liebe Excel Community!

Habe eine Frage, wäre prima, wenn ihr mir helfen könntet.


Arbeite mit Excel 2003.

Ich habe sechs Formeln, in denen wird der Spaltenbereich AL221:AL776 berücksichtigt.
Nun möchte ich bei allen Formeln und Formelteilen, die den Bereich AL221:AL776 aufweisen den Bereich aus der gleichen Spalte AL1225:AL1321, bzw. je nach Formel, zusätzlich aus Spalte AG, AK und AB hinzu addieren.

Später möchte ich ggf. weitere getrennte Bereiche aus der Spalte AL hinzuaddieren.

Mit Punktstrich ";" nach AL776 geht es nicht und mit dem Pluszeichen "+" auch nicht.

Habt ihr eine Idee, was man in den Formeln hinter AL776, hinter AG776 usw. entprechend, einsetzen muss, damit die zwei Bereiche zusammengezählt werden?


1)
=SUMMEWENN(AL221:AL776;"-1")*(-1)



2)
=SUMME(AG221:AG776)



3)
{=MITTELWERT(WENN(AG221:AG776<0;AG221:AG776))}
(ich weiß, geschweifte Klammer mit "Strg+Umschalt + Enter" erzeugen)



4)
=SUMMEWENN(AL221:AL776;">0";AL221:AL776)/SUMMENPRODUKT(ABS(AL221:AL776))



5)
=SUMMENPRODUKT(AK221:AK776;AB221:AB776)/SUMME(AB221:AB776)



6)
=MITTELWERT(AG221:AG776)




Vielen Dank im Voraus für euere Hilfe.

Chris

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
28 Jun 2020 22:18 #2 von Sven
Hallo Chris,

vielleicht verstehe ich nicht richtig, was genau du meinst. Doch wenn ich nun bei 1.) den Bereich AL1225:AL1321 ebenfalls berücksichtigen will, würde ich quasi die komplette Formel in entsprechend angepasster Form mit dem + anhängen. So müssten dann die Ergebnisse beider Formeln addiert werden, das sähe dann so aus:

=SUMMEWENN(AL221:AL776;"-1")*(-1)+SUMMEWENN(AL1125:AL1321;"-1")*(-1)

Ich denke aber, eine allgemeine Lösung gibt es hier eher nicht. Denn deine Formeln haben ja auch unterschiedliche Aufgaben.

Bei 6.) z. B. würde bei diesem Weg etwas falsches herauskommen (Mittelwert 1 + Mittelwert 2 = Mittelwert 3?). Selbst wenn du den Mittelwert 3 dann noch durch 2 teilst, wäre das Ergebnis wahrscheinlich falsch. Hier müsstest du wohl jeweils die Summe und Anzahl herausfinden und diese entsprechend addieren bzw. dividieren.

Prinzipiell also: (Summe von Bereich 1 + Summe von Bereich 2) / (Anzahl von Bereich 1 + Anzahl von Bereich 2)

Gruß

Sven

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.153 Sekunden
Anzeige
Cookies helfen uns bei der Bereitstellung unserer Dienste. Mit der Nutzung dieser Website erklären Sie sich damit einverstanden, dass wir Cookies einsetzen. Weitere Informationen